TRABALHAR COM DATA EM (SOMASES)

NATIJULI
Membro
Membro
Status:
Mensagens: 4
Registro: 04 Jun 2010
Karma: [0] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

TRABALHAR COM DATA EM (SOMASES)

Mensagem por NATIJULI » 04 Jun 2010

Boa tarde,

Estou trabalhando em uma panilha e preciso calcular um valor em reais que esta na coluna G, com os seguintes criterios:

Primeiro criterio, o valor da coluna C tem que ser de um determinado valor , por exemplo "27"
Segundo criterio: com as datas superiores a HOJE que esta na coluna K.
A formula que estou usando e a seguinte.

=SOMASES(G4:G35;C4:C35;"27";K4:K35; "<HOJE")
Com esta formula nao retorna erro, retorna zero
Obrigada

Natijuli

Avatar de usuário
Patropi
Guru
Guru
Status:
Mensagens: 3013
Registro: 28 Nov 2009
Localização: Campo Mourão - PR
Karma: [513] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por Patropi » 04 Jun 2010

Boa tarde Natijuli

Eu não fiz o teste mas experimente colocar a fórmula =HOJE() numa célula como por exemplo J1 e na fórmula coloque o endereço desta célula em substituição ao HOJE.

Exemplo =SOMASES(G4:G35;C4:C35;"27";K4:K35; >J1)

Abraços

Avatar de usuário
JValq
Guru
Guru
Status:
Mensagens: 2152
Registro: 01 Dez 2009
Localização: São Paulo/SP
Karma: [397] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por JValq » 04 Jun 2010

Boa tarde,

A minha sugestão é utilizar a função SOMARPRODUTO:

=SOMARPRODUTO((C4:C35=27)*(K4:K35<HOJE())*G4:G35)

Um abraço
Se achou que a mensagem foi útil, vote positivamente no meu Karma à esquerda da mensagem.

Avatar de usuário
Patropi
Guru
Guru
Status:
Mensagens: 3013
Registro: 28 Nov 2009
Localização: Campo Mourão - PR
Karma: [513] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por Patropi » 06 Jun 2010

Boa noite Natijuli

Quando dei a primeira resposta, no local que eu estava não tinha Excel 2007, por isso não pude testar.

Agora eu testei e tenho a solução para a tua fórmula
Como vc sabe se vc formatar a data como número, por exemplo a data de hoje 06/06/2010 é igual a 40335, pois o excel começa a contar os dias a partir de 1900 e até hoje dá esse número.
Pelo que eu pude perceber a função SOMASES não trabalha com datas.

Eu fiz o seguinte eu coloquei em uma célula a fórmula =HOJE() e formatei como número categoria geral, apresentou o valor de 40335, sendo que a fórmula do SOMASES com este número funcionou normalmente.
Então basta vc usar na fórmula a data de hoje formatada em número que funciona corretamente

=SOMASES(G4:G35;C4:C35;"27";K4:K35;">40335")

Espero que vc tenha entendido e que tenha sido útil pra vc.

Abraços
Se a resposta for útil vote positivamente no meu Karma. Mãozinha Verde à esquerda da mensagem

NATIJULI
Membro
Membro
Status:
Mensagens: 4
Registro: 04 Jun 2010
Karma: [0] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por NATIJULI » 09 Jun 2010

OBRIGADA POR TODAS AS RESPOSTAS ME AJUDARAM MTO.

ATE A PROXIMA


NATIJULI ;)

Luiz Carlos de Souza
Membro
Membro
Status:
Mensagens: 2
Registro: 31 Ago 2010
Karma: [0] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por Luiz Carlos de Souza » 31 Ago 2010

Estou tentando utilizar uma fórmula que some valores cuja data seja menor que a data que estipular. Quando lanço a data em formato de número (40410) a fórmula funciona, mas quando vinculo a uma célula não dá certo (B27). A fórmula usada é:
=SOMASES('Base de dados'!H10:H500;'Base de dados'!L10:L500;A32;'Base de dados'!A10:A500;"<=(b27)"). Onde coluna A = códigos, coluna B=data que quero alterar, coluna base de dados A = data, Base de dados L = códigos e Base de dados H= valores a serem somados.
Agradeço a colaboração.
L. Carlos

Avatar de usuário
Patropi
Guru
Guru
Status:
Mensagens: 3013
Registro: 28 Nov 2009
Localização: Campo Mourão - PR
Karma: [513] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por Patropi » 31 Ago 2010

Boa tarde Luiz Carlos

Veja se esta fórmula te atende. Eu não tive tempo de fazer o teste. Dê retorno.

=SOMARPRODUTO(($L$10:$L$500=A32)*($A$10:$A$500<=B27)*($H$10:$H$500))
Se a resposta for útil vote positivamente no meu Karma. Mãozinha Verde à esquerda da mensagem

Luiz Carlos de Souza
Membro
Membro
Status:
Mensagens: 2
Registro: 31 Ago 2010
Karma: [0] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por Luiz Carlos de Souza » 08 Set 2010

Patropi,
Obrigado, a fórmula funcionou, mas gostaria de mais uma informação: na fórmula a célula B27 é uma data, tenho como colocar uma condição para que o critério seja um intervalo de datas? Por exemplo (B26<=$A$10:$A$500<=B27), onde a célula B26 = primeiro dia do mês e B27 = data a ser informada.
grato
Luiz Carlos

Avatar de usuário
Patropi
Guru
Guru
Status:
Mensagens: 3013
Registro: 28 Nov 2009
Localização: Campo Mourão - PR
Karma: [513] Acrescente 1 ponto ao karma. Tire 1 ponto do karma

Re: TRABALHAR COM DATA EM (SOMASES)

Mensagem por Patropi » 08 Set 2010

Boa tarde Luiz Carlos

Veja aí se funciona porque eu não testei
Célula B26 = Data inical
Célula B27 = Data final

=SOMARPRODUTO(($L$10:$L$500=A32 )*($A$10:$A$500>=B26)*($A$10:$A$500<=B27)*($H$10:$H$500))

Dê retorno.

Abraços
Se a resposta for útil vote positivamente no meu Karma. Mãozinha Verde à esquerda da mensagem


Retornar para Excel

Quem está online

Usuários vendo este fórum: Nenhum usuário registrado online e 13 visitantes

PUBLICIDADE